apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <...@apache.org>
Subject Re: [PATCH] HUP on bug 45930 (CGI and signal masks)
Date Wed, 08 Sep 2010 22:35:10 GMT
On Wed, 8 Sep 2010 13:28:36 +0100
John Sullivan <johns@chiark.greenend.org.uk> wrote:

> Originally submitted with a patch nearly two years ago, this appears
> to have languished. As far as I can tell nothing else has fixed the
> bug in the meantime.
> 
> Could someone with check-in rights take a look at this: I think both
> the problem and solution are straightforward.

You submitted it under APR, but presented an HTTPD bug.
That makes it less likely to get noticed (or taken seriously).

There are a couple of issues.

One: cross-platform issues: your patch is in /unix/ but references OS2.
That flashes up "can't test so leave it" in me, and no doubt in other
*X-oriented folks.  Only on replying did I look carefully enough to
figure out it doesn't in fact affect OS2.

Two: the problem description is using httpd mod_cgi with a threaded MPM.
This is a configuration that is explicitly not recommended: mod_cgid
(or fastcgi) are documented as preferable.  Easy to miss the underlying
issue you're reporting!

Three: apr is a library, and HTTPD is just one user among many.
A change that might have side-effects on something else belongs
in trunk only.

Having said all that, bug me if I don't get around to reviewing it
and either committing to trunk or raising objections in bugzilla.

-- 
Nick Kew

Mime
View raw message