Hi all,

I've tested the fix "Ryan Phillips" posted. It did work for my case.
But I'm not sure if it's right or not..

Index: sockopt.c
===================================================================
--- sockopt.c	(revision 532161)
+++ sockopt.c	(working copy)
@@ -102,7 +102,7 @@
     /* must disable the incomplete read support if we disable
      * a timeout
      */
-    if (t <= 0) {
+    if (t < 0) {
         sock->options &= ~APR_INCOMPLETE_READ;
     }
     sock->timeout = t;

Thanks

Best regards,
honercek


On Wed, Jun 2, 2010 at 4:50 PM, Chen Chien-Yu <honercek@gmail.com> wrote:
Hi all,

I've been suffering from a problem for more than 1 week. The client will get stuck when reading a page from Apache, it just waits for the zero-chunk being sent from the Apache.

This post (http://mail-archives.apache.org/mod_mbox/httpd-users/201005.mbox/%3CAANLkTinKrR60LOYct3eYtmCLwZAvL9OR3e8pWGOY72_K@mail.gmail.com%3E) describes the problem I met. 

After some debugging and analyses (http://mail-archives.apache.org/mod_mbox/httpd-users/201006.mbox/%3cAANLkTinwenme6xwGtPokzCMHhK5sHKAaFcVFAQRlWU0e@mail.gmail.com%3e), it seems the problem is caused by the APR library when processing  the bucket reading, an infinite loop?!

Then I found a post in this mail list with similar symptom as mine (http://mail-archives.apache.org/mod_mbox/apr-dev/200704.mbox/%3C20070425010624.GA46804@zeus.kimaker.com%3E), and another discussion that might be related to my problem (http://mail-archives.apache.org/mod_mbox/apr-dev/200405.mbox/%3c20040507002929.GA19761@manyfish.co.uk%3e).

But the post about "blocking bucket reads on non-blocking sockets" was in 2004, it's 6 years ago.
The Apache version I'm using is 2.2.15, the newest stable version, I don't think the bug fix wouldn't include in the version.

How can I make sure the fix was included? Or do you guys have any idea about my problem?

Thanks

Best regards,
honercek