apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chen Chien-Yu <honer...@gmail.com>
Subject Re: HTTP doesn't work after upgrading from 2.0.55 to 2.2.15
Date Fri, 04 Jun 2010 13:04:29 GMT
Hi Ryan,

Thanks for your support.
I'm not quite sure what you mean..
Does that mean I have to build the code in srclib/apr/test and
srclib/apr-util/test, and run the test on my target machine
(cross-compiling)
If it is, then I did run them and have some problems. But have no exact idea
how to fix them.. The information on the Internet about this is few.

srclib/apr/testall -v testfmt
testfmt             : |Line 50: expected <0>, but saw <2>

Line 61: expected <0>, but saw <2>

FAILED 2 of 9
Failed Tests            Total   Fail    Failed %
===================================================
testfmt                     9      2     22.22%


srclib/apr/testall -v testlock
testlock            : -Line 188: rwlocks not implemented

SUCCESS
All tests passed.


srclib/apr/testall -v testlfs
testlfs             : \Line 239: seek to 8GB - 4 (22): Invalid argument
Bus error


srclib/apr/testall -v testmmap
testmmap            : /Line 77: expected <0>, but saw <2>

Segmentation fault


srclib/apr/testall -v testsockets
testsockets         : |Line 67: IPv6 not enabled

Line 82: IPv6 not enabled

Line 108: IPv6 not enabled

SUCCESS
All tests passed.

========================================================================================

srclib/apr-util/testall -v testqueue
testqueue           : \Line 103: expected <0>, but saw <70023>
Segmentation fault

srclib/apr-util/testall -v testpass
testpass            : \Line 96: expected <0>, but saw <70023>
Segmentation fault

srclib/apr-util/testall -v testreslist
testreslist         : |Line 228: expected <0>, but saw <70023>

Segmentation fault

srclib/apr-util/testall -v testxlate
testxlate           : -Line 63: expected <0>, but saw <22>

FAILED 1 of 1
Failed Tests            Total   Fail    Failed %
===================================================
testxlate                   1      1    100.00%


Thanks

Best regards,
honercek


On Fri, Jun 4, 2010 at 1:06 PM, Ryan Phillips <ryan@trolocsis.com> wrote:

> On Wed, Jun 2, 2010 at 4:28 AM, Chen Chien-Yu <honercek@gmail.com> wrote:
> > Hi all,
> > I've tested the fix "Ryan Phillips" posted. It did work for my case.
> > But I'm not sure if it's right or not..
> >
> > Index: sockopt.c
> > ===================================================================
> > --- sockopt.c (revision 532161)
> > +++ sockopt.c (working copy)
> > @@ -102,7 +102,7 @@
> >      /* must disable the incomplete read support if we disable
> >       * a timeout
> >       */
> > -    if (t <= 0) {
> > +    if (t < 0) {
> >          sock->options &= ~APR_INCOMPLETE_READ;
> >      }
> >      sock->timeout = t;
>
> Make sure to run the apr unit tests on the target to double check
> configure detected all the correct settings... I'm pretty sure that
> was our problem. We don't apply the patch I posted anymore (although
> it could still be correct).
>
> Regards,
> Ryan
>

Mime
View raw message