apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Cooper <robert.cooper...@gmail.com>
Subject Building apr-util with ldap on AIX
Date Wed, 21 Apr 2010 15:45:12 GMT
Hello,

I am having trouble building apr-util with ldap on AIX.  I have successfully
build apr and openssl with the following options:
apr
CC="gcc" ./configure -C --prefix=/usr/local/apr
openssl
CC="gcc" ./configure -C --enable-slapd --enable-hdb=no --enable-bdb=no
--prefix=/usr/local/openldap

I have tried building apr-util multiple times with different options.  Here
what I think is close to right:
CPPFLAGS="-I/usr/local/openssl" LDFLAGS="-L/usr/local/openssl" CC="gcc"
./configure -C --prefix=/usr/local/apr-util \
--with-apr=/usr/local/apr --enable-ldap --with-ldap

Here is the output from the apr-util configure:
checking for ldap support...
checking for ldap_init in -lldap50... no
checking for ldap_init in -lldapssl41... no
checking for ldap_init in -lldapssl40... no
checking for ldap_init in -lldapssl30... no
checking for ldap_init in -lldapssl20... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
configure: error: could not find an LDAP library
Is there a file ldap_init that should exist in /usr/local/openssl?
Any input would be greatly appreciated.

Thanks,
Robert

Mime
View raw message