apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: httpd trunk, apr/apu 1.4 branches and Linux
Date Fri, 23 Apr 2010 13:40:35 GMT

On Apr 23, 2010, at 9:31 AM, Jeff Trawick wrote:

> On Fri, Apr 23, 2010 at 8:58 AM, Jim Jagielski <jim@jagunet.com> wrote:
>> (sorry for the cross-post but httpd-trunk and APR are now so
>> entwined that its required)...
>> 
>> OK... I've been playing around with building httpd-trunk
>> on Linux and I've been having troubles left and right (using
>> the 1.4 branches of both apr and apr-util installed right
>> in ./srclib)...
>> 
>> First of all, Ubuntu 8.10 can't even get past a top level
>> ./buildconf (likely due to libtool issues (2.2.4)... But
>> Ubuntu 9.10 dies when getting to build apr-util due to
>> expat issues (can't find the system installed version and
>> the bundled version's config/make is toast)...
> 
> Hmmm...
> 
> my Ubuntu 9.10 x86
> 
> ./buildconf
> found apr source: srclib/apr
> found apr-util source: srclib/apr-util
> rebuilding srclib/apr/configure
> buildconf: checking installation...
> buildconf: python version 2.6.4 (ok)
> buildconf: autoconf version 2.64 (ok)
> buildconf: libtool version 1.5.26 (ok)

Weird... my default libtool is 2.2.6 under 9.10...


> 
>> 
>> checking Expat 1.95.x... no
> 
> checking Expat 1.95.x... yes
>  setting APRUTIL_EXPORT_LIBS to "-lexpat"
>  setting APRUTIL_LIBS to "-lexpat"
> 
> 

So far, if I install libtool 2.2.6b, expat 2.0.1 and pcre 8.02
then I can get to at least a completed compile, both with Ubuntu
8.10 and 9.10.

Mime
View raw message