apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@xbc.nu>
Subject Re: [VOTE] APR versioning rules w.r.t. released snapshots
Date Tue, 15 Dec 2009 22:42:46 GMT
William A. Rowe Jr. wrote:
> Branko ─îibej wrote:
>   
>> William A. Rowe Jr. wrote:
>>     
>>> Unfortunately the APR versioning rules do not tell the developer not to compile
>>> against or link to -dev, while this gives the user no indication of what they
>>> are doing to their APR installation.
>>>   
>>>       
>> in that, you're correct. One would expect that developers do assume
>> that, but it needs to be documented. Why not add that bit to
>> versioning.html? It's quite a reasonable addition.
>>
>> For example, Subversion, which uses the exact same versioning rules as
>> APR, regularly ships rlease candidates marked "-rc" and no-one worries
>> about breaking the ABI to fix a bug between an RC and a release.
>>     
>
> Should apr_initialize and friends be programmed to go 'bang' and drop out
> with a stderr emit, if compiled against a x.y.0-dev release and run against
> x.y.*[1-9]?  Or, at least a stderr warning at initialization time?
>
> Seems like a simple, sensible fix.
>   
Yes, it does. A runtime version check in apr_initialize is an eminently
good idea. I'll see about adding one, like, right now.

-- Brane


Mime
View raw message