apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@xbc.nu>
Subject Re: svn commit: r890580 - in /apr/apr-util/branches/1.4.x: crypto/apr_crypto.c crypto/apr_crypto_nss.c crypto/apr_crypto_openssl.c include/apr_crypto.h include/private/apr_crypto_internal.h test/testcrypto.c
Date Tue, 15 Dec 2009 10:06:25 GMT
Graham Leggett wrote:
> William A. Rowe Jr. wrote:
>
>   
>> This is ABI breakage from 1.4.0-dev to 1.4.1, please revert; extend with an
>> apr_crypto_error_ex for querying from an arbitrary interface.  It doesn't make
>> sense why we would want this, but ...
>>     
>
> What is 1.4.0-dev?
>
> This API appears in none of our releases, why suddenly is this API cast
> in stone?
>   

Because Paul in his wisdom released HTTPD with an unreleased APR bundled
with it. Which implies that some users have that unreleased APR, labeled
1.4, installed on their systems. Which is the source of all this back
and forth between Bill and Paul.

Sigh.

-- Brane

Mime
View raw message