apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Semyon <semyon.ka...@gmail.com>
Subject Re: APR library + Solaris 5.10 + 64bit problem
Date Wed, 16 Dec 2009 18:12:11 GMT

It does not help, I also tryed APR 1.4.1 - it does not work


Jeff Trawick wrote:
> 
> On Wed, Dec 16, 2009 at 11:55 AM, Semyon <semyon.karev@gmail.com> wrote:
> 
>> I've got a problem after building native library for Tomcat.
>> Settings:
>> Tomcat 6.0.20
>> APR 1.3.9
>> JNI 1.1.16
>> JDK 1.6_u17
>> OS: SunOS 5.10 sparcv9
>> compiler: gcc -m64
>>
>> It has built ok, and APR has gone all tests (gmake test). Tomcat starts
>> well
>> with APR libs. But when I'm trying to make HTTPS connection with server
>> from
>> firefox browser, I'm getting error like "Connection Interrupted". HTTP
>> connection works well. I've tryed to use Internet Explorer 6 - it works
>> well.
>> I suppose that there is something wrong with 64bit build version, because
>> before I built native library with 32bit and everything works well!
> 
> You need some post-APR 1.3.9 fixes.
> 
> Get the latest port.c from svn (or
> http://svn.apache.org/viewvc/apr/apr/branches/1.3.x/poll/unix/port.c?view=log)
> and copy that over APR 1.3.9's poll/unix/port.c and report back on how
> that works.
> 
> 

-- 
View this message in context: http://old.nabble.com/APR-library-%2B-Solaris-5.10-%2B-64bit-problem-tp26814474p26815791.html
Sent from the APR Dev (Apache Portable Runtime) mailing list archive at Nabble.com.


Mime
View raw message