apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: svn commit: r835634 - in /apr/apr-util/branches/1.4.x: buildconf xml/expat/buildconf.sh xml/expat/configure.in
Date Mon, 16 Nov 2009 18:56:42 GMT
On Mon, Nov 16, 2009 at 12:01 PM, William A. Rowe Jr.
<wrowe@rowe-clan.net> wrote:
> Jeff Trawick wrote:
>>>
>>> Modified: apr/apr-util/branches/1.4.x/xml/expat/buildconf.sh
>>> URL: http://svn.apache.org/viewvc/apr/apr-util/branches/1.4.x/xml/expat/buildconf.sh?rev=835634&r1=835633&r2=835634&view=diff
>>> ==============================================================================
>>> --- apr/apr-util/branches/1.4.x/xml/expat/buildconf.sh (original)
>>> +++ apr/apr-util/branches/1.4.x/xml/expat/buildconf.sh Thu Nov 12 23:20:20 2009
>>
>>> @@ -42,12 +47,12 @@
>>>  cat $ltfile >> aclocal.m4
>>>
>>>  if [ -f ltsugar.m4 ]; then
>>> -  echo "Incorporating ltsugar.m4 into aclocal.m4 ..."
>>> -  cat ltsugar.m4 >> aclocal.m4
>>> +   rm -f conftools/ltsugar.m4
>>> +   mv ltsugar.m4 conftools/ltsugar.m4
>>>  fi
>>>
>>> -# Clean up again
>>> -rm -f libtool.m4 ltsugar.m4
>>> +# Clean up any leftovers
>>> +rm -f aclocal.m4 libtool.m4
>>
>> removing aclocal.m4 is a killer for me with
>>
>> - Solaris 10
>> - in-tree expat
>> - autoconf 2.61
>> - libtool 1.5.26
>> - automake 1.11
>
> That's cut and paste from apr, hrmmm.  Happy to take a second look at this.
>
>> AC_PROG_LIBTOOL and AC_LIBTOOL_WIN32_DLL aren't found.
>>
>> Find the discussions around r388605 too ;)
>
> So not 'in general', only after libtoolizing them rm'ing aclocal.m4?

I'm not sure what you mean here... we create aclocal.m4 based on
libtool.m4 then whack it almost immediately; aclocal.m4 is where
autoconf would find AC_PROG_LIBTOOL et al.


> I will go
> back and take a second look at what we did in apr-1.x vs xml/expat/
>

apr is a little different...  it uses libtool.m4 to create
build/libtool.m4, and APR's configure.in does
sinclude(build/libtool.m4).

hmmm... you changed xml/expat/configure.in to
sinclude(conftools/libtool.m4); I guess conftools is where you
expected it to be?

libtoolize (1.5.26) doesn't create libtool.m4 anywhere in the
xml/expat tree; it ends up being copied from libtool's
share/aclocal/libtool.m4 to aclocal.m4

Mime
View raw message