apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: comments on configure.in r835608
Date Mon, 16 Nov 2009 17:07:47 GMT
On Fri, Nov 13, 2009 at 8:35 PM, Jeff Trawick <trawick@gmail.com> wrote:
> On Fri, Nov 13, 2009 at 8:19 PM, William A. Rowe Jr.
> <wrowe@rowe-clan.net> wrote:
>> Jeff Trawick wrote:
>>> I see these warnings with autoconf 2.61:
>>>
>>> configure.in:220: warning: AC_LIBTOOL_SETUP was called before
>>> AC_LIBTOOL_WIN32_DLL
>>> build/libtool.m4:1902: AC_LIBTOOL_WIN32_DLL is expanded from...
>>> configure.in:220: the top level
>>> buildconf: creating configure ...
>>> configure.in:220: warning: AC_LIBTOOL_SETUP was called before
>>> AC_LIBTOOL_WIN32_DLL
>>> build/libtool.m4:1902: AC_LIBTOOL_WIN32_DLL is expanded from...
>>> configure.in:220: the top level
>>
>> Seeing this in 2.59 (libtool 1.5.18), and managed to fix it.
>>
>> There should be no emits on older or newer autotool chains, for apr-x.x flavors,
>> except 0.9 which is up for discussion.
>>
>
> cool
>
> meanwhile, httpd make install started going ballistic trying to
> install a DSO module via libtool "recently"
>
> autoconf 2.61, libtool 1.5.22, OpenSolaris, httpd trunk, apr-1.4.x,
> apr-util-1.4.x
>
> Making install in generators
> /export/home/trawick/inst/apr14/build-1/libtool --silent
> --mode=install install mod_cgid.la
> /export/home/trawick/inst/23/modules/
> find: stat() error /export/home/trawick/inst/23/modules/mod_cgid.so:
> No such file or directory
> find: cannot read dir /etc/inet/secret: Permission denied
...

the issue seems to be the use of /usr/sbin/install instead of
ginstall, and isn't obviously related to apr/apr-util

Mime
View raw message