apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Poirier <poir...@pobox.com>
Subject APR 1.4.x, 1.0.x on Snow Leopard
Date Mon, 12 Oct 2009 12:43:31 GMT
I'm still not having much luck with apr 1.4.x or 1.0.x on Snow Leopard.  Just curious
if my problems are unique?  

Since 1.4.x failed, and Snow Leopard's installed apr is called
libapr-1.0.3.5.dylib, I also tried apr-1.0.x.

On 1.4.x, buildconf fails; on 1.0.x; configure fails, so in both cases,
I don't get far enough to even apply apple's patch for include/apr.h.
include/apr.h.

[08:35:01]poirier@slappy:~/apache/apr-1.4.x$ ./buildconf
buildconf: checking installation...
buildconf: python version 2.6.1 (ok)
buildconf: autoconf version 2.61 (ok)
buildconf: libtool version 2.2.4 (ok)
Copying libtool helper files ...
$_prefix/share/aclocal/libtool.m4 not found
[08:35:12]poirier@slappy:~/apache/apr-1.4.x$ printenv PATH
/bin:/usr/bin

... check out 1.0.x ...  buildconf succeeds ... run configure ...

checking for minix/config.h... no
checking whether system uses EBCDIC... no
performing libtool configuration...
./configure: line 9381: syntax error near unexpected token `lt_decl_varnames,'
./configure: line 9381: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'
[08:39:36]poirier@slappy:~/apache/apr-1.0.x$

Mime
View raw message