It also seems like aprutil.mak is looking for 'include/apr.hw' in APR, however no such file exists in the tarball. If I rename the 'apr.h' that exists in there to 'apr.hw' it works. Also, the LIB files generated are not placed in 'apr-util/Release' as expected, they remain in LibR.

---------
Robert Dailey


On Sat, Aug 8, 2009 at 1:32 PM, Robert Dailey <rcdailey@gmail.com> wrote:
Hey William,

I just downloaded APR util 1.3.9 and APR 1.3.8 and I am still unable to build on Windows. Below is the output I'm getting. Are there certain steps I need to follow once I download the tarballs? Files I have to rename? etc?

E:\IT\personal\haresvn\temp\apr-util>nmake -f libaprutil.mak

Microsoft (R) Program Maintenance Utility Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.

No configuration specified. Defaulting to libaprutil - Win32 Release.
        cd ".\xml\expat\lib"
        "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\BIN\nmake.exe" /                   /F ".\xml.mak" CFG="xm
l - Win32 Release"

Microsoft (R) Program Maintenance Utility Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.

        if not exist ".\LibR/" mkdir ".\LibR"
        tempfile.bat
        tempfile.bat
        cl.exe @C:\Users\Robert\AppData\Local\Temp\nm9A38.tmp
xmlparse.c
xmlrole.c
xmltok.c
Generating Code...
        link.exe -lib @C:\Users\Robert\AppData\Local\Temp\nm9D56.tmp
        cd "..\..\.."
        cd ".\..\apr-iconv\ces"
        NMAKE /nologo /f Makefile.win BUILD_MODE="Win32 Release" BIND_MODE=shared
cesiconv.c
_tbl_simple.c
LINK : fatal error LNK1181: cannot open input file '..\..\apr\Release\libapr-1.lib'
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\BIN\link.EXE"' : return code '0x49d'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\BIN\NMAKE.EXE"' : return code '0x2'
Stop.

---------
Robert Dailey



On Tue, Jul 21, 2009 at 12:26 PM, Robert Dailey <rcdailey@gmail.com> wrote:
That's understandable. I was just checking in.

I'm sure you'll let me know when you've gotten around to it.

Thanks for the update and keep up the great work!

---------
Robert Dailey



On Tue, Jul 21, 2009 at 11:45 AM, William A. Rowe, Jr. <wrowe@rowe-clan.net> wrote:
Hi Robert - sadly I was laid up in mod_fcgid and mod_ftp, but with
the pending release now of apr 1.3.7, I have to be in that code
today.

Bill

Robert Dailey wrote:
> William,
>
> How did your testing go on Saturday?
>
> ---------
> Robert Dailey
>
>
> On Sat, Jul 18, 2009 at 2:23 AM, William A. Rowe, Jr.
> <wrowe@rowe-clan.net <mailto:wrowe@rowe-clan.net>> wrote:
>
>     Hey Robert - something is really wrong.
>
>     Let me experiment on Saturday.
>
>     Bill
>
>