not a -1; just something to think about in the future
On Wed, Jul 1, 2009 at 5:38 PM, Bojan Smojver <email@example.com>
On Wed, 2009-07-01 at 08:31 -0400, Jeff Trawick wrote:That is what the original patch had, in fact. I kinda liked the locally
> IMO the better way to handle this would have been
> int ret, tmpret;
> and using tmpret when the function-wide ret shouldn't be touched
> Overloading "ret" and the semi-hidden setting of the function-wide ret
> make this code less clear than it could be.
scoped approach better, because it seemed cleaner to me. But then again,
I'm not known for very good taste.
> Continuing down the overly picky trail: It would be better to focus
> CHANGES entries on the impact to library consumers, and omit details
> like "locally[-]scoped variables".
Question: was your comment essentially a -1, in which case I'll
revert/change, or was it just a remark?