apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Dailey <rcdai...@gmail.com>
Subject Re: Problem building using nmake on Windows
Date Wed, 15 Jul 2009 04:28:58 GMT
On Tue, Jul 14, 2009 at 8:29 PM, William A. Rowe, Jr.
<wrowe@rowe-clan.net>wrote:

> Robert Dailey wrote:
> > I would really appreciate a response to the inquiry quoted below.
> >
> > On Mon, Jun 22, 2009 at 9:57 PM, Robert Dailey <rcdailey@gmail.com
> > <mailto:rcdailey@gmail.com>> wrote:
> >
> >     Hi,
> >
> >     Currently I have the following versions:
> >
> >     apr: 0.9.18
> >     apr-iconv: 0.9.7
> >     apr-util: 0.9.17
> >
> >     I've renamed all of them to their respective names in the same
> >     directory as the build instructions require.
>
> The goal in this package was to avoid that aspect of the instructions,
> provided you identify the paths of apr, apr-util and apr-iconv.  However
> it seems things did not work out as planed;


How do I specify the paths of apr, apr-util, and apr-iconv without renaming
them?


>
>
> >     I go to the apr-util directory and execute:
> >
> >     nmake /f aprutil.mak
> >
> >     It looks like things build normally until I see this (Note that this
> >     is just a snippet from the very bottom of all the output, there is
> >     far more above but I have left it out):
> >
> >     NMAKE : fatal error U1073: don't know how to make '"apr.h"'
> >     Stop.
> >
> >     Notice the error at the bottom of the snippet above. Why is this
> >     happening?
>
> I suspect it is because I attempted to to introduce ${INCLUDES} into the
> dependencies, to find the related packages, and fix the search path to pick
> up the includes.
>
> In the apr\ tree, please try doing a 'del *.dep /s' and let me know if that
> fixes things for you.  I plan to resolve this and repackage.  The 2nd most
> recent apr 1.3 release suffered from similar issues, and with the newest
> apr 1.3 release I scuttled this effort for an entirely different approach.


I will try this and get back with you later. Thanks a lot for your help.

Mime
View raw message