apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: [MAINTAINER] devel/apr-gdbm-db42: apr-util 1.3.7 breaks dbd support
Date Tue, 09 Jun 2009 07:50:19 GMT
Bojan Smojver wrote:
> So, there are apps out there that specifically depend on -ldb being
> returned by apu-1-config? Can you give me an example so that I can get
> my head around this better?
> PS. Subversion itself depends on Berkeley DB directly, not through APU,
> so passing that to ./configure there should be sufficient to build it.
> At least it worked for me (although the syntax of the argument itself
> can be daunting:
> --with-berkeley-db=db.h:/path/to/includedir:/path/to/libdir:db).
Yes, thats the one that is used when we add support to both subversion
and apr.

Though in fbsd its typically -- /usr/local/include/db46:/usr/local/lib/db46

I'll get you a list of the apps tomorrow, I don't have access to my box atm.

View raw message