apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: [MAINTAINER] devel/apr-gdbm-db42: apr-util 1.3.7 breaks dbd support
Date Wed, 10 Jun 2009 21:44:00 GMT
On Wed, 2009-06-10 at 18:58 +0200, Arfrever Frehtes Taifersar Arahesis
wrote:
> As a Subversion developer, I would not like to see more useless
> libraries in the output of `apu-1-config --libs`. apu-1-config doesn't
> ignore unrecognized options, so we couldn't unconditionally pass
> --avoid-dbm option.

We do this in libapreq2:
-----------------------
if $APU_CONFIG --avoid-ldap >/dev/null 2>&1; then
  APR_ADDTO([APR_LIBS], "`$APU_CONFIG --avoid-ldap --libs`")
else
  APR_ADDTO([APR_LIBS], "`$APU_CONFIG --libs`")
fi
-----------------------

I guess you could do that with --avoid-dbm too, since you probably don't
want to drag in LDAP either.

> I also think that the syntax of argument of --with-berkeley-db option
> of Subversion's configure script is logical and appropriate :) .

Of course it makes sense. SVN links directly to it, not via APU (i.e. it
doesn't use apr_dbm*()).

-- 
Bojan


Mime
View raw message