Gentlemen, I don't think that you should use version 6.0 of the Microsoft development compiler and linker and in fact, nobody should use it because Microsoft dropped its support since late 2005, if I remember correctly. Alternately, you could at least provide the .sln and .vcproj files for a newer version of the Developer's Studio.
 
I am just a user and this is just a suggestion; I am not trying to boost Microsoft sales :-).