apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Comstock <st...@trainersfriend.com>
Subject Adrift with Apache
Date Thu, 03 Jul 2008 17:41:38 GMT
We pick up the story of our intrepid adventurer
trying to port Apache 2.2.9 to z/OS 1.9. ...



When we last left him, we was planning to run buildconf
as a preparatory step to the Apache configure. You may
recall this scene from the end of the last episode...



OK. Seems to have gone OK. Guess I'm ready to run buildconf

Yikes!! :

ADMINS:/Z19/usr/lpp/zApache/httpd-2.2.9: >./buildconf
found apr source: srclib/apr
found apr-util source: srclib/apr-util
rebuilding srclib/apr/configure
buildconf: checking installation...
buildconf: python not found.
            You need python installed
            to build APR from SVN.
./buildconf failed for apr


python? I need to install python? How come the docs don't
mention this?


... now we resume the tale...

OK. Guess I'll go get python (I was hoping someone would
jump in with a workaround; or at least an explanation as
to why python was not mentioned in the instructions).

Google is your friend: python z/OS

   http://www.teaser.fr/~jymengant/mvspython/mvsPythonPort.html

seems to contain the latest port of python, at level 2.4.1
which is only slightly down level from the general latest
version of python at 2.5

OK. Got it intstalled with a little help from Jean-Yves.



Try again:

ADMINS:/Z19/usr/lpp/zApache/httpd-2.2.9: >./buildconf
found apr source: srclib/apr
found apr-util source: srclib/apr-util
rebuilding srclib/apr/configure
buildconf: checking installation...
buildconf: python version entering (ok)
buildconf: autoconf not found.
            You need autoconf version 2.50 or newer installed
            to build APR from SVN.
./buildconf failed for apr


But... autoconf 2.54 _is_ installed; it comes with tools N toys
(ported tools) already mentioned, and it is in the PATH.

So, found /usr/local/bin contains autotconf that is late enough,
so added that to the PATH. Then...

ADMINS:/Z19/usr/lpp/zApache/httpd-2.2.9: >./buildconf
found apr source: srclib/apr
found apr-util source: srclib/apr-util
rebuilding srclib/apr/configure
buildconf: checking installation...
buildconf: python version entering (ok)
buildconf: autoconf version 2.54 (ok)
buildconf: libtool version 1.3.4 found.
            You need libtool version 1.4 or newer installed
            to build APR from SVN.
./buildconf failed for apr

but this is the libtool that was ported from the Apache for
z/OS page because it was non-GNU.

Looks like I need to have a newer non-GNU libtool, one
that has been 'tweaked' for z/OS. Anyone have any pointers
or suggestions?


Kind regards,

-Steve Comstock
The Trainer's Friend, Inc.

303-393-8716
http://www.trainersfriend.com

   z/OS Application development made easier
     * Our classes include
        + How things work
        + Programming examples with realistic applications
        + Starter / skeleton code
        + Complete working programs
        + Useful utilities and subroutines
        + Tips and techniques

==> Check out the Trainer's Friend Store to purchase z/OS  <==
==> application developer toolkits. Sample code in four    <==
==> programming languages, JCL to Assemble or compile,     <==
==> bind and test.                                         <==
==>   http://www.trainersfriend.com/TTFStore/index.html    <==



Mime
View raw message