apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Glasser" <glas...@davidglasser.net>
Subject Re: Can't change current.tmp to current, failed for futher import
Date Tue, 08 Jul 2008 00:01:55 GMT
On Wed, Jul 2, 2008 at 6:50 AM, Penghai Wang <pwang2188@yahoo.com> wrote:
> Hi,
>
> I have seen several report regarding current.tmp problem there, it sounds should be resolved
in late releases but I am still suffering this problem in 1.4.3.
>
> Hear is my setting and problems I got:
>
> Installed SVN 1.4.3 with Apache 2 on a Windows XP Pro box (via XAMPP), the repo is configured
on local disk C, hppd is running under an admin user, so the repo should have full privileges
for the repo. The fs is fsfs, all file operation via file:// protocol, any operation such
as import , delete or rename a file, create a directory could be failed because the following
problem:
>
> When import, rename, or delete a file, a quite high chance to get a svn exception, saying:
>
> Can't move <repo>/db/current.tmp to <repo>/db/current.
>
> Once this happened, no further svn operation can be execute, whatever import a new file,
or rename an existing one, or other any operation will be failed with following exception:
> svn: Revision already exists
>
> After dig into several similar messages from googling (see some workaround such as chmod
-R o-t, but it is not the case for Windows), I dig into repo/db directory, manually removed
current.tmp file, removed same revision numer in the current.tmp under revs and revprops,
bounced the apache, it work again although I lost last file I tried to import (or other  operation).
However, the same problem could happens again very quickly, this makes the svn not usable
for my case.
>
> I have noticed 1.5 has been released, I believe that the above problem should be resolved
in the earlier releases (earlier than 1.4.3) because it was in APR bucket for a while, same
problem seem only associated with FSFS, not BDB. My questions are:
>
> 1) Is this problem resolved in 1.5 with FSFS on Windows?

The simple answer here is "why don't you try it and tell us"?  1.5.x
contains several years worth of changes over 1.4.x; I don't know if it
contains a fix for your bug or not, but if it doesn't, we'd like to
know.

--dave

--dave

> 2) Is there any other workaround or solutions I could use?
>
> Thanks,
>
> --Pen
>
>
>
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org
>
>



-- 
David Glasser | glasser@davidglasser.net | http://www.davidglasser.net/

Mime
View raw message