apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jimi HullegÄrd <jimi.hulleg...@mogul.com>
Subject RE: Strange continous SEVERE error after upgrading to APR 1.3, Critical poller failure, Timer expired
Date Wed, 25 Jun 2008 13:22:16 GMT
Nick Kew wrote:

> On Wed, 2008-06-25 at 12:43, Nick Kew wrote:
> >
> > Could this be related to
> > http://marc.info/?l=apr-dev&m=121347872322492&w=2
> >
> > I had something similar with httpd+Event MPM on solaris.
> > Current workaround is to use Worker MPM.
>
> OK, I've just tested APR variants with Event MPM.
>
> It is indeed that fix that breaks it.  When I revert
> the fix, the problem goes away.
>
> The original patch posted to fix the same bug works fine.
> Can I suggest you apply the following patch to 1.3.x
> (should work on 1.3.0 or 1.3.2 too) and let us know if
> it fixes the problem you're seeing?
>
> [patch code snipped]

Ok, I have forwarded this to some persons that have access to the system now (I am currently
at a different office with no remote access). I hope they have time to test this soon.

/Jimi

Mime
View raw message