apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jimi HullegÄrd <jimi.hulleg...@mogul.com>
Subject RE: Strange continous SEVERE error after upgrading to APR 1.3, Critical poller failure, Timer expired
Date Wed, 25 Jun 2008 12:33:44 GMT
> -----Original Message-----
> From: Nick Kew [mailto:nick@webthing.com]
> Sent: den 25 juni 2008 13:44
> To: dev@apr.apache.org
> Subject: Re: Strange continous SEVERE error after upgrading
> to APR 1.3, Critical poller failure, Timer expired
>
> On Wed, 25 Jun 2008 10:32:58 +0200
> Jimi HullegÄrd <jimi.hullegard@mogul.com> wrote:
>
> > Hi,
> >
> > After we upgraded APR from 1.2.8 to 1.3.0 we get a strange error in
> > tomcat's catalina.out that we have never seen before:
> >
> > Jun 24, 2008 11:42:09 AM
> > org.apache.tomcat.util.net.AprEndpoint$Poller run SEVERE: Critical
> > poller failure (restarting poller): [62] Timer expired
>
> Could this be related to
> http://marc.info/?l=apr-dev&m=121347872322492&w=2
>
> I had something similar with httpd+Event MPM on solaris.
> Current workaround is to use Worker MPM.

I'm not quite sure I follow you now... Worker MPM is for Apache Httpd, right? We don't use
httpd. Do you know of any workaround for Tomcat?

/Jimi

Mime
View raw message