apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jimi HullegÄrd <jimi.hulleg...@mogul.com>
Subject Strange continous SEVERE error after upgrading to APR 1.3, Critical poller failure, Timer expired
Date Wed, 25 Jun 2008 08:32:58 GMT
Hi,

After we upgraded APR from 1.2.8 to 1.3.0 we get a strange error in tomcat's catalina.out
that we have never seen before:

Jun 24, 2008 11:42:09 AM org.apache.tomcat.util.net.AprEndpoint$Poller run
SEVERE: Critical poller failure (restarting poller): [62] Timer expired

This is repeated over and over, at approximately 5-10 times per second. If we switch back
to APR 1.2.8, and not touching anything else, then this error message goes away.

We use Tomcat 5.5.23 on Solaris 10 (Sun X2200 and X2100). We have tried with APR 1.3.2 and
the result was the same as for 1.3.0. As far as I can tell, a regular poll time out should
not result in this error, but still I tried increasing the pollTime from the default 2000
(2ms) to 20000 (20ms) for the connectors in server.xml (http://tomcat.apache.org/tomcat-5.5-doc/apr.html)
but that didn't change anything.

I have investigated the tomcat process using the truss command (like strace I guess, but for
solaris) right from the tomcat startup, and this is the first 3000 lines of the output:

http://pastebin.com/f60671b83

If you search for "ETIME" (the name of the error message "Timer expired") you can see that
the first occurence (at line 2545)is at about 1 second after startup (so it seems that it
is not triggered by a request). The thread in questions is thread number 6.

Here is the truss log file for the first 20 minutes or so, filtered to only include the thread
6:

http://pastebin.com/f3fd14e2c

There were also other threads that experienced this "Err#62 ETIME", but thread number 6 seems
to be the one with the most number of these errors. Also, when restarting tomcat it is always
the thread number 6 that has the this error first and has the most number of occurences of
it.

Does the message "Critical poller failure (restarting poller): [62] Timer expired" or the
truss log output tell you guys anything about what can be wrong? Could it be a bug? Is there
something wrong with our web application? The thing is that we haven't noticed anything wrong
with it so far, besides these annoying error messages in catalina.out.

Regards
/Jimi


mogul | jimi hullegÄrd | system developer | hudiksvallsgatan 4, 113 30 stockholm sweden |
+46 8 506 66 172 | +46 765 27 19 55 | jimi.hullegard@mogul.com | www.mogul.com

Mime
View raw message