apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Erenkrantz" <jus...@erenkrantz.com>
Subject Re: svn commit: r669927 - in /apr/apr/trunk: build/buildcheck.sh configure.in
Date Fri, 20 Jun 2008 16:59:26 GMT
On Fri, Jun 20, 2008 at 8:58 AM, William A. Rowe, Jr.
<wrowe@rowe-clan.net> wrote:
>  dnl Various OS checks that apparently set required flags
> -AC_AIX
> +AC_USE_SYSTEM_EXTENSIONS
>  AC_ISC_POSIX
> -AC_MINIX

Isn't it possible to do some m4 conditionals based on the autoconf
version instead?  Not as clean, but it won't force our developers to
upgrade to 2.6x.  I think it'd be something close to:

ifelse(regexp(AC_ACVERSION, 2\.6), -1, [
AC_AIX
AC_MINIX],[
AC_USE_SYSTEM_EXTENSIONS
])

HTH.  -- justin

Mime
View raw message