apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@gbiv.com>
Subject Re: svn commit: r669927 - in /apr/apr/trunk: build/buildcheck.sh configure.in
Date Fri, 20 Jun 2008 15:11:23 GMT
-1.  That breaks the build for all maintainers using OS X 10.4.x and
I don't see any reason to require it.

% which autoconf
/usr/bin/autoconf
% autoconf --version
autoconf (GNU Autoconf) 2.59

....Roy


On Jun 20, 2008, at 5:01 PM, wrowe@apache.org wrote:

> Author: wrowe
> Date: Fri Jun 20 08:01:12 2008
> New Revision: 669927
>
> URL: http://svn.apache.org/viewvc?rev=669927&view=rev
> Log:
> Autoconf 2.60's 2nd birthday this coming thursday.  As this
> is for maintainers, it's time to bump.
>
> Modified:
>     apr/apr/trunk/build/buildcheck.sh
>     apr/apr/trunk/configure.in
>
> Modified: apr/apr/trunk/build/buildcheck.sh
> URL: http://svn.apache.org/viewvc/apr/apr/trunk/build/buildcheck.sh? 
> rev=669927&r1=669926&r2=669927&view=diff
> ====================================================================== 
> ========
> --- apr/apr/trunk/build/buildcheck.sh (original)
> +++ apr/apr/trunk/build/buildcheck.sh Fri Jun 20 08:01:12 2008
> @@ -14,18 +14,18 @@
>  echo "buildconf: python version $py_version (ok)"
>  fi
>
> -# autoconf 2.50 or newer
> +# autoconf 2.60 or newer
>  ac_version=`${AUTOCONF:-autoconf} --version 2>/dev/null|sed -e 's/^ 
> [^0-9]*//;s/[a-z]* *$//;q'`
>  if test -z "$ac_version"; then
>  echo "buildconf: autoconf not found."
> -echo "           You need autoconf version 2.50 or newer installed"
> +echo "           You need autoconf version 2.60 or newer installed"
>  echo "           to build APR from SVN."
>  exit 1
>  fi
>  IFS=.; set $ac_version; IFS=' '
> -if test "$1" = "2" -a "$2" -lt "50" || test "$1" -lt "2"; then
> +if test "$1" = "2" -a "$2" -lt "60" || test "$1" -lt "2"; then
>  echo "buildconf: autoconf version $ac_version found."
> -echo "           You need autoconf version 2.50 or newer installed"
> +echo "           You need autoconf version 2.60 or newer installed"
>  echo "           to build APR from SVN."
>  exit 1
>  else
>
> Modified: apr/apr/trunk/configure.in
> URL: http://svn.apache.org/viewvc/apr/apr/trunk/configure.in? 
> rev=669927&r1=669926&r2=669927&view=diff
> ====================================================================== 
> ========
> --- apr/apr/trunk/configure.in (original)
> +++ apr/apr/trunk/configure.in Fri Jun 20 08:01:12 2008
> @@ -139,9 +139,8 @@
>  AC_CHECK_TOOL(AR, ar, ar)
>
>  dnl Various OS checks that apparently set required flags
> -AC_AIX
> +AC_USE_SYSTEM_EXTENSIONS
>  AC_ISC_POSIX
> -AC_MINIX
>
>  APR_EBCDIC
>
>
>


Mime
View raw message