apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Comstock <st...@trainersfriend.com>
Subject Problems with configure
Date Fri, 20 Jun 2008 03:07:50 GMT
I'm struggling a little here, and I'm new at the Apache
community, so I'm not sure this is the right place to
post. Feel free to tell me where to go if this is not
the right place. :-)

Trying to port Apache 2.2.9 to z/OS 1.9. It's taken a
lot of preliminary work, but I think I'm ready to try
a configure. But I guess not, since that is failing.
Sigh. So here are the symptoms, and I'm hoping someone
can suggest some things to try:

Note: directory scheme is /usr/lpp/zApache/httpd-2.2.9



1. If I run:

./configure --prefix=/usr/lpp/zApache -n --enable-charset-lite --enable-proxy 
--with-port=8080

[mind the wrap; it all fits on one line on my system]


Among other things, I get the message:

configure: WARNING: Unrecognized options: --enable-charset-lite, --enable-proxy, 
--with-port

The docs specifically list these as valid options for configure.
Perhaps I keyed something incorrectly?



2. Puzzled, I run the configure this way:

./configure --prefix=/usr/lpp/zApache -n

and I get rid of that warning message, but I still have these:

trap: ./configure 2113: FSUM7327 signal number 13 not conventional

[not a very helpful message; and, from Google and other
  sites it seems to be very common. can anyone shed any
  light on why I get this and how to fix it?]

.
.
.
checking for APR... reconfig
configuring package in srclib/apr now 

trap: /Z19/usr/lpp/zApache/httpd-2.2.9/srclib/apr/configure 2047: FSUM7327 
signal number 13 not conventional
    [Can someone explain to me what's going on,
     and how to fix this? The docs indicate to me
     I can just use the bundled apr and apr-util
     programs, so I'm all confused on this.]

.
.
.
checking for gcc... no
checking for cc... cc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
configure failed for srclib/apr

   [well, I have a good C/C++ compiler installed,
    so there is some other error here.]


A side light that may shed some light on this:
the one doc on installing Apache on z/OS talks
about having the GNU autoconf and m4 programs
installed, although I can't see where they are
ever used. What I have downloaded are:

autoconf-2.54-ebcdic-bin.pax
autoconf.pax.Z.bin

which I am led to believe contain the aforementioned
autoconf and m4.

TIA for any help you can give me on this.


Kind regards,

-Steve Comstock
The Trainer's Friend, Inc.

303-393-8716
http://www.trainersfriend.com

   z/OS Application development made easier
     * Our classes include
        + How things work
        + Programming examples with realistic applications
        + Starter / skeleton code
        + Complete working programs
        + Useful utilities and subroutines
        + Tips and techniques

==> Check out the Trainer's Friend Store to purchase z/OS  <==
==> application developer toolkits. Sample code in four    <==
==> programming languages, JCL to Assemble or compile,     <==
==> bind and test.                                         <==
==>   http://www.trainersfriend.com/TTFStore/index.html    <==

Mime
View raw message