apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: new packages are at autoconf 2.62 / libtool 1.5.26
Date Mon, 16 Jun 2008 04:56:24 GMT
On Sat, 2008-06-14 at 21:24 -0500, William A. Rowe, Jr. wrote:
> and based on raw gnu packages, not fedora's idea of a good schema.
> 
> Hit this one in our config...
> 
> configure.in:144: warning: AC_COMPILE_IFELSE was called before 
> AC_USE_SYSTEM_EXTENSIONS
> ../../lib/autoconf/specific.m4:385: AC_USE_SYSTEM_EXTENSIONS is expanded from...
> ../../lib/autoconf/specific.m4:456: AC_MINIX is expanded from...
> configure.in:144: the top level
> configure.in:144: warning: AC_RUN_IFELSE was called before 
> AC_USE_SYSTEM_EXTENSIONS

I'm guessing this:
------------------
dnl Various OS checks that apparently set required flags
AC_AIX
AC_ISC_POSIX
AC_MINIX
------------------

Should be higher up in configure.in.

Maybe we should even replace it with:
------------------
dnl Various OS checks that apparently set required flags
AC_USE_SYSTEM_EXTENSIONS
AC_ISC_POSIX
------------------

Apparently, AC_USE_SYSTEM_EXTENSIONS includes AC_GNU_SOURCE, AC_AIX,
and AC_MINIX.

-- 
Bojan


Mime
View raw message