apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: sqlite3 and postgresql
Date Sun, 18 May 2008 04:49:08 GMT
Quoting Bob Rossi <bob_rossi@cox.net>:

> Aren't you worried about how that will break all the existing programs
> out there using this interface?

This is one of those damned if we fix it, damned if we don't things :-)

That being said, this is clearly a bug, as APU's DBD is supposed to be  
database neutral as much a possible (i.e. you should be able to change  
the underlying driver and still have most of the stuff just work). For  
that reason, it should be fixed.

In terms of strict binary compatibility, 1.2.x most likely cannot be  
changed here because we state here  
http://apr.apache.org/versioning.html#strategy that for the Patch  

"Changes to the API, to the signatures of public functions, or to the  
interpretation of function parameters is not allowed."

AFAICT, Minor Versions do not have this particular requirement, so we  
should be OK to fix this in 1.3.x.

PS. We already did similar changes to DBD functions in 1.3.x.


View raw message