apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Rossi <bob_ro...@cox.net>
Subject Re: dbd pgsql autotools patch
Date Fri, 16 May 2008 03:18:49 GMT
On Fri, May 16, 2008 at 11:21:46AM +1000, Bojan Smojver wrote:
> On Thu, 2008-05-15 at 09:08 -0400, Bob Rossi wrote:
> > So,
> > I get a link error, because it needs to link against -lcrypt.
> 
> What kind of system do you have? Where does the -lcrypt live on your
> system?

Ubuntu 7.04, /lib/libcrypt-2.5.so

> BTW, doing the pg_config --libs will not give us the right thing here.
> For instance, on my system, this returns:
> 
> -lpgport -lxslt -lxml2 -lpam -lssl -lcrypto -lgssapi_krb5 -lz -lreadline
> -lcrypt -ldl -lm
> 
> Many of these things are most definitely not needed for the client to be
> linked in (i.e. the --libs gives libraries used to build PostgreSQL, not
> ones required to link to pq). We have to find a better way to do this...

OK, perhaps we should just add -lcrypt to the pg line? I could check to
see if this works on my system if you think this is a good idea.

Bob Rossi

Mime
View raw message