apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Re: LDAP over SSL on Win32
Date Thu, 20 Mar 2008 18:08:55 GMT
Hi all,
> Thank you for your work with this, and for sending it to me.

> Unfortunately, it does not solve the problem I am having.  But, at least
> now
> the error message is consistent across all 3 version of Windows that I
> have
> been working with!

> I am copying the APR DEV mailing list so they can take a look at this.
well, either my mailserver did cut the attached bits, or it lost somewhere else....
Harry, or Victor, can one of you perhaps send it to me? thanks in advance.

Regarding LDAPS at all: I also tested a lot with the M$ implementation with another project,
and didnt get it properly working - finally I used either an OpenLDAP Win32 port,
or the Novell CLPAP SDK which both worked then fine for me.

I think we should probably look into this direction since supporting LDAPS with M$ implementation
is really a pain;
the Novell CLDAP SDK is freely available - you only have to register:
http://developer.novell.com/wiki/index.php/LDAP_Libraries_for_C
at least we should make it switchable for the Win32 build, and that shouldnt be much trouble
since we have full support for this SDK already in due to the NetWare port using it.

Although OpenLDAP would be an option too - I'm not aware of any MSVC port;
with the other project I mentioned I used an older MingW32 port....

Guenter.



Mime
View raw message