apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harry Holt" <harryh...@gmail.com>
Subject Re: LDAP over SSL on Win32
Date Mon, 10 Mar 2008 11:26:14 GMT
On Fri, Mar 7, 2008 at 12:00 PM, Víctor <victorjss@gmail.com> wrote:

> Sorry by emailing you, but I am not subscribed to any Apache list. I had
> the same problem with Windows 2000 Server and ldaps connections, and I spent
> almost a whole week hunting the bug (wireshark usage included), finding your
> post. The problem is with the compiled version of apr-util,
> libaprutil-1.dll, that makes calls to wldap32.dll. This dll is different
> in Windows XP-2003 and in Windows 2000 (see link<http://www.talkaboutsoftware.com/group/microsoft.public.adsi.general/messages/27941.html>),
> and you need to modify apr_ldap_option.c from APR' sources. I attach
> original file, modified one, and resulted DLL. I successfully test this new
> library on Windows XP and Windows 2000, and now I can connect by ldaps with
> my repository.
>
> If any of you could send this little collaboration to the APR project, I
> would appreciate.
>


> Regards
>
>
>
> Víctor
>
>
Thank you for your work with this, and for sending it to me.

Unfortunately, it does not solve the problem I am having.  But, at least now
the error message is consistent across all 3 version of Windows that I have
been working with!

I am copying the APR DEV mailing list so they can take a look at this.

Thx... HH

-- 
Harry Holt, PMP

Mime
View raw message