apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Querna <c...@force-elite.com>
Subject Re: building on Solaris 10 with gcc - some tests failing and slow
Date Fri, 08 Feb 2008 11:56:35 GMT
Manuel Polling wrote:
> Hi all,
> I am trying to get APR 1.2.12 built on Solaris 10 using gcc as provided
> by Sun (version 3.4.3) in /usr/sfw. I want both a 64-bit and a 32-bit
> version. The builds seem to have succeeded. To make sure that everything
> is ok I tried to run ./testall in the test/ directory. This seems to run
> into some problems:
> 
>     * some tests are partially failing and the testsock test seems to
>       hang (I left the process running unattended for a night)
>       testdso             :  FAILED 8 of 9
>       testflock           :  FAILED 2 of 3
>       testpipe            :  FAILED 1 of 9
>       testpoll            :  FAILED 1 of 13
>       testproc            :  FAILED 2 of 3
>       testshm             :  FAILED 1 of 6
>       testsock            :
>     * a number of tests take a lot of time to complete, in particular
>       testpipe but there are other as well. "A lot of time" means at
>       least several minutes but getting up to 15-30 minutes or more
>       (testpipe is an example of that). On Linux the same tests finish
>       in 1 or 2 minutes and only testshm fails 1 test.

Test poll/socket are known issues with patches available:
http://issues.apache.org/bugzilla/show_bug.cgi?id=43000
http://mail-archives.apache.org/mod_mbox/apr-dev/200712.mbox/%3C369011d00712032222p38c14477n1ecf13dbba5abc4@mail.gmail.com%3E

-Paul

Mime
View raw message