apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonia Tugores <atugo...@gridsystems.com>
Subject win32, apr_process_create and cmd.exe
Date Thu, 31 Jan 2008 09:55:49 GMT

Hi everybody, 

I'm having some troubles with apr_process_create in win32 platforms. When I 
try to execute cmd.exe the result is a message like "The system can't find the 
specified path". The command type I used is APR_SHELLCMD_ENV, so cmd is in 
the path. With other applications it worked fine, the only one that fails is 
cmd.exe.

In http://markmail.org/message/opveualuzkdkz4ea I found this:
"On windows, some process such as cmd.exe would mysteriously fail to start if 
they didn't exist in a console, e.g. when cmd.exe is run in a service 
context. Both bugs can be hard to track down for the typical user."

I tried setting apr_procattr_detach_set to true, but it didn't work.

Can anybody give me a clue?

By the way, I am not using pipes nor std_out/err files, and the apr version I 
use is 1.2.11.

M. Antonia


Mime
View raw message