apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henry Jen" <henry...@ztune.net>
Subject Re: Any libtool/autoconf guru have 20 minutes to hack?
Date Tue, 30 Oct 2007 07:06:24 GMT
Attached is a patch giving the -version-info, works for me.

However, I am not sure if this is enough, as in ccs/ces, the libtool
is called with -avoid-version, which makes me suspicious the version
is left out on purpose.

HTH,
Henry

On 10/29/07, William A. Rowe, Jr. <wrowe@rowe-clan.net> wrote:
> William A. Rowe, Jr. wrote:
> > libapriconv trunk would appreciate a small tweak here;
> >
> > apr.exp      libapr-1.so         libapriconv-1.so        libaprutil-1.so
> > aprutil.exp  libapr-1.so.0       libapriconv-1.so.0      libaprutil-1.so.0
> > iconv        libapr-1.so.0.2.12  libapriconv-1.so.0.0.0
> > libaprutil-1.so.0.2.12
> > libapr-1.a   libapriconv-1.a     libaprutil-1.a          pkgconfig
> > libapr-1.la  libapriconv-1.la    libaprutil-1.la
> >
> > Note it's not identified as libapriconv-1.so.0.2.1 (trunk rev from
> > api_version.h).
> >
> > I don't consider it a showstopper, but it would be nicer if we fixed before rolling
> > version 1.2.2.  The right hacker could do this in 1/10th the time it would take
me
> > to figure this out :)
>
> ping?  any helper good at version decorations?
>

Mime
View raw message