apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: MySQL DBD driver only supports 4.1+?
Date Tue, 16 Oct 2007 09:01:04 GMT
On Mon, 15 Oct 2007 17:07:47 -0700
"Justin Erenkrantz" <justin@erenkrantz.com> wrote:

> apr-util fails to compile on Solaris 10 because it detects the bundled
> MySQL libraries in /usr/sfw, but the MySQL version (4.0.24) is
> apparently too old.  apr_dbd_mysql.c is looking for MYSQL_STMT - which
> doesn't appear in the 4.0.x client releases, but, AFAICT, appears only
> in the 4.1+ releases.
> 
> Should we be refusing to accept MySQL versions <4.1 then?  Or, is it
> trivial to support 4.0?  -- justin

Speaking from rather patchy memory here:

I expect it would be possible to support older versions, but it
would involve a substantial rewrite.  4.1 had a whole new API
for prepared statements, which our driver uses extensively.

-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

Mime
View raw message