apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myers, Gary - 43" <gary.my...@rainhail.com>
Subject RE: Using apr from Mingw
Date Mon, 09 Jul 2007 20:32:55 GMT
Well that figures that I'm using some oddball configuration.  I'll go
configure MSYS, and give that a try.

Thanks for the answer I appreciate it.

Gary Myers 

-----Original Message-----
From: Bob Rossi [mailto:bob_rossi@cox.net] 
Sent: Monday, July 09, 2007 3:14 PM
To: Myers, Gary - 43
Cc: dev@apr.apache.org
Subject: Re: Using apr from Mingw

On Mon, Jul 09, 2007 at 03:01:17PM -0500, Myers, Gary - 43 wrote:
> I already have the dll's built.  I just used MSVC to built it since it
> was easier, which I admit was lazy of me.  What I am getting is a
> compile time error when I try to compile the C Source file that
includes
> two of the apr header files.  My guess is that Mingw treats something
> different that I'm not taking into account.  I should add that I'm not
> using the MSYS prompt to do this I'm doing my coding in Eclipse 3.3
with
> the C\C++ plugin, and I'm manually writing the Makefile, because using
> the managed one was a small nightmare, and I was unable to get this
far.
> The result of typing make at the DOS prompt was that long list of
errors
> from my first message.  I can get all the other pieces of my project
to
> compile fine, but when I introduce apr into the compilation process it
> won't compile due to an errors that gcc is finding in several header
> files.  So I pulled all the other code that I had written, and put in
> the simple C file that I sent in my first post, and the problem
> persists.  I don't know where else to turn for an answer

I have never tried this configuration. Sorry. I've only built apr in a
msys window, and compiled my applicatoin there as well. Maybe someone
else has experience in this area...

Bob Rossi


Mime
View raw message