apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [Vote] Release APR 1.2.9/0.9.14 and apr-iconv 1.2.0
Date Wed, 06 Jun 2007 21:19:45 GMT
Lucian Adrian Grijincu wrote:
> I took http://apr.apache.org/dev/dist/apr-1.2.9.tar.gz
> Hope I'm on target now:)
> 
> I've done two tests. One in which I ran buildconf myself and one without.
> For each test I then ran:
> ./configure
> make
> make test
> 
> Both failed with:
> testsockets         : \/bin/bash: line 1: 10039 Segmentation fault
> (core dumped) ./$prog
> 
> the line possition it reports differs from run to run.
> 
> Same system: Ubuntu 7.04, 32bit.
> 
> Also:
> Still haven't checked if this is to be expected running ./test/testall
> gives:
> testatomic          : SUCCESS
> testdir             : SUCCESS
> testdso             : FAILED 8 of 9
> testdup             : SUCCESS
> testenv             : SUCCESS
> testfile            : SUCCESS
> testfilecopy        : FAILED 2 of 4
> testfileinfo        : SUCCESS
> testflock           : FAILED 2 of 3
> testfmt             : SUCCESS
> testfnmatch         : FAILED 2 of 2
> testargs            : SUCCESS
> testhash            : SUCCESS
> testipsub           : SUCCESS
> testlock            : SUCCESS
> testlfs             : SUCCESS
> testmmap            : |Segmentation fault (core dumped)
> 
> Even though they pass when run from make check.

Yow :(

would you try running within gdb and give us the where's?  You might
need to recompile with CFLAGS=-g for debugging symbols.

Bill

Mime
View raw message