apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eddie Epstein" <eaepst...@gmail.com>
Subject Fwd: [Bug 41386] - apr_dso_load ignores DYLD_LIBRARY_PATH on Mac OSX
Date Fri, 18 May 2007 13:59:22 GMT
Finally got access to the OSX machine. config.log reported:
  configure:11077: checking whether the gcc linker (/usr/bin/ld)
supports shared libraries
  configure:11973: result: yes
  configure:12044: checking dynamic linker characteristics
  configure:12598: result: darwin8.8.1 dyld

The change to make apr_dso_load this work properly is:

diff dso.c*
27,32d26
< #if defined(DSO_USE_DYLD)
< #define DSO_USE_DLFCN
< #undef DSO_USE_DYLD
< #endif
<
<

Regards,
Eddie

---------- Forwarded message ----------
From: Eddie Epstein <eaepstein@gmail.com>
Date: Apr 27, 2007 5:49 PM
Subject: [Bug 41386] - apr_dso_load ignores DYLD_LIBRARY_PATH on Mac OSX
To: dev@apr.apache.org


Hi,

Unfortunately I have lost access to the Mac used for development and
cannot check the output of configure. I will try to get back access to
the machine in order to check the configure log.

 There are two other pieces of information that could be of interest.
First, a small C program using dlopen() respected DYLD_LIBRARY_PATH
properly. Second, the v1.2.7 apr built and installed by Darwin ports
also had a broken apr_dso_load().

Regards,
Eddie

------- Additional Comments From jorton@redhat.com  2007-04-26 09:26 -------
The autoconf code was explicitly written to check for dyld.  Are you sure there
are no Darwin platforms which e.g. have a present but broken dlopen?  Can you
bring this up on dev@apr?

Mime
View raw message