apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: Need help in compiling apr-util on RedHat 4
Date Thu, 08 Mar 2007 20:31:38 GMT
You can't mix apr-0.9 and apr-util-1.x.  The fact that you don't have
a build-1 directory is the dead giveaway (apr-0.9 stored it's files in
build, not build-1.)  They should coexist peacefully if you install
both apr-0.9.(recent) and apr-1.2.x in the same prefix.

ying lcs wrote:
> Hi,
> 
> I am trying to compile apr-util on Red Hat 4.
> I have successfully make and install apr on Red hat 4.
> 
> # cd /usr/local/apr/
> [root@REDHAT3 apr]# ls
> bin  build  include  lib
> 
> But when I try to run 'configure '  for  apr-util-1.2.2, It keep
> saying it can't find apr.
> I have tried ./configure --with-apr=/usr/local/apr/, it does not work
> either.
> 
> Can anyone please help me?
> 
> Thank you.
> 
> 
> [root@REDHAT3 apr-util-1.2.2]# ./configure
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> checking target system type... i686-pc-linux-gnu
> checking for a BSD-compatible install... /usr/bin/install -c
> checking for working mkdir -p... yes
> APR-util Version: 1.2.2
> checking for chosen layout... apr-util
> Applying apr-util hints file rules for i686-pc-linux-gnu
> checking for APR... no
> configure: error: APR could not be located. Please use the --with-apr
> option.
> [root@REDHAT3 apr-util-1.2.2]#
> 
> 


Mime
View raw message