apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From генерал Пурпоз <kb2...@gmail.com>
Subject Porting APR-UTIL to QNX4: portability problems.
Date Mon, 05 Feb 2007 19:46:19 GMT
Hello dev,

 Having a sort of "ported" APR v1.2.8 library I tryed to port APR-UTIL
 v1.2.8

 "testall" reports 100% passage.
 Some tests (the "testqueue" and the "testreslist") just report they
 badly need the threads to run.
 The "testrmm" does not build because of no shared memory.
 The "testxlate" complains about no UTF-8 support...
 The "testdate" blows as expected - I still could not obtain the
 proper version of the "clib" with int64-aware scanf|printf.

 And the "testxml" reports some unidentifyed "internal error". It
 prints lots of screens of the following:
0: element mary
1: element had
1:      attrs   a=little        
1: element lamb
1:      attrs   its=fleece was white as snow    
1: element hmm
1:      attrs   for=dinner      roast=lamb      
1: element hmm
1:      attrs   for=dinner      roast=lamb      

<...a huge snip...>

1: element hmm
1:      attrs   for=dinner      roast=lamb      
1: element hmm
1:      attrs   for=dinner      roast=lamb      
APR Error Internal error
XML Error: XML parser error code: mismatched tag (7) (EXPECTED) This is good.

The expat library passed it's own tests and also was perceived as
100%-usable in the neon's testsuite.

I wonder if I'm doomed...
Please comment.

-- 
Best regards,
 Anthony                  mailto:kb2wjw@gmail.com


Mime
View raw message