apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: upgrade issues
Date Sat, 24 Feb 2007 20:02:57 GMT
Babu, Natakam wrote:
> I am very much new to Apache products, my current project uses Apache
> Http Server 1.3, I am in the process of migrating these project modules
> to use 2.0 version of the server.
> 
> I have replaced the 1.3 headers with the 2.0 headers with-in my project
> code base. Now when I build my project it throws the following errors, I
> tried to search on the net and specifically on the apache website, but I
> did not get any thing significant and hence I am writing to this mailing
> list:
> 
> c:\temp\tradecentral\3rd-party\apache\httpd-api\include\apr_allocator.h(66)
> : error C2955: 'allocator' : use of class template requires template
> argument list

what exact version of apr/httpd and your compiler?  If these declarations
in apr_pools.h are buried  in the namespace "C" then this shouldn't happen,
but maybe VC 6 had some issues with this, or maybe the namespace was overlooked
in the earlier apr source.  Does switching the order of includes headers help?


Mime
View raw message