apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Rossi <bob_ro...@cox.net>
Subject Re: mingw build
Date Thu, 30 Nov 2006 19:52:07 GMT
On Thu, Nov 30, 2006 at 07:29:32AM -0800, Justin Erenkrantz wrote:
> On 11/30/06, Bob Rossi <bob_rossi@cox.net> wrote:
> >Does anyone know the status of building apr with mingw on windows?
> 
> If you use trunk, MinGW should work fine.  -- justin

Hi Justin,

I've also tried this,

  $ CFLAGS=-mno-cygwin ./configure --build=mingw32

which get's my past the previous problems, but the configure dies here:

  checking for long long... yes
  checking size of long long... 8
  configure: error: could not detect a 64-bit integer type

Do you have any suggestions on how to configure apr on cygwin with
mingw? Note that this configuration allows me to have thread support. Is
that OK? Will my house blow up if I link to this library?

One other though, I get messages like this:
  checking sys/uio.h usability... no
  checking sys/uio.h presence... yes
  configure: WARNING: sys/uio.h: present but cannot be compiled
  configure: WARNING: sys/uio.h:     check for missing prerequisite
  headers?
  configure: WARNING: sys/uio.h: see the Autoconf documentation
  configure: WARNING: sys/uio.h:     section "Present But Cannot Be
  Compiled"
  configure: WARNING: sys/uio.h: proceeding with the preprocessor's result
  configure: WARNING: sys/uio.h: in the future, the compiler will take
  precedence
  checking for sys/uio.h... yes

This doesn't seem correct. Any suggestions on if this is "normal"? If
not, any suggestions on how to resolve the problem?

The attached configure file is below.

Thanks,
Bob Rossi

Mime
View raw message