apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Rossi <bob_ro...@cox.net>
Subject Re: mingw build
Date Thu, 30 Nov 2006 17:01:14 GMT
On Thu, Nov 30, 2006 at 07:29:32AM -0800, Justin Erenkrantz wrote:
> On 11/30/06, Bob Rossi <bob_rossi@cox.net> wrote:
> >Does anyone know the status of building apr with mingw on windows?
> 
> If you use trunk, MinGW should work fine.  -- justin

Hi Justin, 

Thanks for the quick reply. 

Unfortunately, this didn't work for me. I'm using mingw via cygwin. The
first problem I ran into was this:

  $ ./buildconf 
  buildconf: checking installation...
  buildconf: python version 2.4.3 (ok)
  buildconf: autoconf version 2.60 (ok)
  buildconf: libtool not found.
	     You need libtool version 1.4 or newer installed
	     to build APR from SVN.

  $ libtool --version

  ltmain.sh (GNU libtool) 1.5.23a (1.1220.2.412 2006/10/13 14:13:30)

  Copyright (C) 2006  Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

So, I modified build/buildcheck.sh with the attached patch. I'm sure the
patch isn't "correct", but it helped me get a build going.

Now, I did 

  CFLAGS=-mno-cygwin ./configure 2>&1 | tee out.txt

to configure apr, but it failed with:
  checking for /dev/zero... yes
  ./configure:Error: decision on anonymous shared memory allocation method failed

Any idea why this is?

Finally, apr still doesn't work with the posix thread library on cygwin.
  Checking for Threads...
  APR will be non-threaded
Do you know why?

I found out that if I do ./configure --build=mingw32, then I get a
threaded build. I'm not sure if this is safe though. Any recommendations?
Attached is the patch to buildcheck and the output of configure.

Thanks,
Bob Rossi

Mime
View raw message