apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Stein" <gst...@gmail.com>
Subject Re: current dbd initiatives
Date Wed, 14 Jun 2006 13:50:20 GMT
On 6/14/06, Nick Kew <nick@webthing.com> wrote:
>...
> > >> > 5) Renaming functions like apr_dbd_get_entry() to apr_dbd_entry_get().
> > >> > Is this the kind of thing that can be done with a minor version number
> > >> > change, i.e., in 1.3?
>
> I thought we established that apr_module_verb_noun is the form used most
> commonly throughout apr-util in any case!

Whatever. That is a separate discussion/debate; I was merely trying to
provide options within the versioning guidelines.

For the above case, the function implementation can be renamed to
apr_dbd_entry_get(), then a new function can be added, named
apr_dbd_get_entry, which simply calls the other with its params.
Update the header to rename the function, and add a new entry for the
old with a @deprecated remark.

Don't try to use #define here tho. Some users may want/need the func
address, so you can't use macros. Also, as Bill points out, you can't
convert the old func to a macro.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message