apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Erenkrantz" <jus...@erenkrantz.com>
Subject Re: io abstractions
Date Thu, 29 Jun 2006 14:05:48 GMT
On 6/28/06, david reid <david@jetnet.co.uk> wrote:
> I avoided using _io_... as what else could it be? Also there won't be
> any other _read or _write as everything is abstracted away, so it seemed
> surplus to requirements.

I think it's more in line with our naming conventions that we stick to
placing the type of the passed structure in the function name.

We had apr_read and apr_write before and I thought that wasn't very
descriptive.  If we say it is 'apr_io_write", then the dev knows it
has something to do with our custom I/O abstraction (and purposefully
isn't an analogue to read()/write() syscalls).  -- justin

Mime
View raw message