apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Greig" <sgr...@altair.com>
Subject RE: Compiling with __USE_LARGEFILE64 on linux (RH8).
Date Mon, 15 May 2006 12:45:39 GMT
My bad, I've been using -D_LARGEFILE64_SOURCE just typed it wrong in the
email.
I also need -D_FILE_OFFSET_BITS=64.  Both flags are used to build my
main application.

I tried running configure on a RH8 machine.

configure CFLAGS="-D_FILE_OFFSET_BITS=64" --enable-lfs

I get the following message:
...
Check for compiler flags...
Checking whether to enable -D_LARGEFILE64_SOURCE... no

If I remove the CFLAGS setting it works fine.

- Scott




> -----Original Message-----
> From: Joe Orton [mailto:jorton@redhat.com] 
> Sent: Monday, May 15, 2006 3:33 AM
> To: dev@apr.apache.org
> Subject: Re: Compiling with __USE_LARGEFILE64 on linux (RH8).
> 
> On Fri, May 12, 2006 at 04:47:33PM -0400, Scott Greig wrote:
> > I tried rebuilding apr(1.1.1) with LFS enabled.  There 
> seemed to be a 
> > problem with simply passing '--enable-lfs' to configure.  The 
> > configure script temporarily adds the -D__USE_LARGEFILE64 
> then removes 
> > it using $apr_save_CPPFLAGS?
> > 
> > So I forced it to add -D__USE_LARGEFILE64 to CPPFLAGS and setting 
> > APR_HAS_LARGE_FILES=1.
> > Still the apr_dir_read fails to return the correct file names. 
> 
> You should never be defining __USE_LARGEFILE64, that is a 
> glibc-private macro.  If you build any APR 1.x release it 
> will have LFS support out of the box (on a suitable platform, 
> which RHL8 should be); don't pass anything to configure.
> 
> So firstly build APR 1.2.7 without any such flags, and 
> rebuild your application against that APR.  Make sure you are 
> building your app with `apr-1-config --cppflags` in CPPFLAGS 
> somewhere; this should include -D_LARGEFILE64_SOURCE.  Then 
> describe exactly what your app does, and how it fails (APR 
> error codes, simple repro case, strace output).
> 
> joe
> 

Mime
View raw message