apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: svn commit: r390549 - /apr/apr-util/trunk/include/apr_dbd.h
Date Mon, 03 Apr 2006 05:14:15 GMT
Bojan Smojver wrote:
> Quoting Garrett Rooney <rooneg@electricjellyfish.net>:
>> There's no reason for compat macros, this code has not been released
>> in any version of APR, so compat is not an issue.
> I was referring to renaming all DBD functions actually (including the  
> new ones), so that they follow the naming proper convention (ie.  
> lib_object_subobject_verb). Or is that too much to change at once?

Right - I wasn't being critical of your specific new fn, but just a general
observation.  In the past, we created renames_proposed to collect a list for
review and comment before committing the changes; if you agree with the
syntax _get _set etc, then let's start that list again.

Where you took the naming from - made your choice very consistent.  I was
commenting on the consistency of the libraries as a whole :)


View raw message