apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: svn commit: r390549 - /apr/apr-util/trunk/include/apr_dbd.h
Date Mon, 03 Apr 2006 05:30:49 GMT
Quoting "William A. Rowe, Jr." <wrowe@rowe-clan.net>:

> Right - I wasn't being critical of your specific new fn, but just a general
> observation.  In the past, we created renames_proposed to collect a list for
> review and comment before committing the changes; if you agree with the
> syntax _get _set etc, then let's start that list again.

apr_dbd_get_driver -> apr_dbd_driver_get
apr_dbd_check_conn -> apr_dbd_conn_check
apr_dbd_set_dbname -> apr_dbd_dbname_set
apr_dbd_get_row    -> apr_dbd_row_get
apr_dbd_get_entry  -> apr_dbd_entry_get
apr_dbd_get_name   -> apr_dbd_name_get

I picked this list up from here (hopefully I didn't miss any):


I don't think we need to touch private functions. Users never see them  
anyway. And it's always good to confuse ourselves - just when you  
think you got the hang of the naming convention, the private functions  
don't follow it ;-)


View raw message