apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bojan Smojver <bo...@rexursive.com>
Subject Re: svn commit: r390549 - /apr/apr-util/trunk/include/apr_dbd.h
Date Sun, 02 Apr 2006 22:59:29 GMT
Quoting "William A. Rowe, Jr." <wrowe@rowe-clan.net>:

> When did we drift back to this naming convention?
>
> I thought we were trying to move twords lib_object_subobject_verb?
>
> E.g. apr_dbd_name_get?
>
> It's really aggrivating to use an api that's pulling in both directions
> at once :(

Sorry about that. I was simply trying to follow the existing  
convention inside DBD (ie. get_driver, get_row etc.). But we can  
always change the lot, define a bunch of macros for backward  
compatibility, which can then be pronounced deprecated.

Would it be useful to create patches along these lines?

-- 
Bojan

Mime
View raw message