apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: svn commit: r390549 - /apr/apr-util/trunk/include/apr_dbd.h
Date Sat, 01 Apr 2006 02:56:31 GMT
When did we drift back to this naming convention?

I thought we were trying to move twords lib_object_subobject_verb?

E.g. apr_dbd_name_get?

It's really aggrivating to use an api that's pulling in both directions
at once :(

Bill

niq@apache.org wrote:
> Author: niq
> Date: Fri Mar 31 16:28:12 2006
> New Revision: 390549
> 
> URL: http://svn.apache.org/viewcvs?rev=390549&view=rev
> Log:
> Commit the b**** API for get_name, dammit!
> 
> Modified:
>     apr/apr-util/trunk/include/apr_dbd.h
> 
> Modified: apr/apr-util/trunk/include/apr_dbd.h
> URL: http://svn.apache.org/viewcvs/apr/apr-util/trunk/include/apr_dbd.h?rev=390549&r1=390548&r2=390549&view=diff
> ==============================================================================
> --- apr/apr-util/trunk/include/apr_dbd.h (original)
> +++ apr/apr-util/trunk/include/apr_dbd.h Fri Mar 31 16:28:12 2006
> @@ -223,6 +223,17 @@
>  APU_DECLARE(const char*) apr_dbd_get_entry(const apr_dbd_driver_t *driver,
>                                             apr_dbd_row_t *row, int col);
>  
> +/** apr_dbd_get_name: get an entry name from a result set
> + *
> + *  @param driver - the driver
> + *  @param res - result set pointer
> + *  @param col - entry number
> + *  @return name of the entry, or NULL if col is out of bounds.
> + */
> +APU_DECLARE(const char*) apr_dbd_get_name(const apr_dbd_driver_t *driver,
> +                                          apr_dbd_results_t *res, int col);
> +
> +
>  /** apr_dbd_error: get current error message (if any)
>   *
>   *  @param driver - the driver
> 
> 
> 
> .
> 


Mime
View raw message