apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Alex.Krumm-Hel...@csiro.au>
Subject RE: using APR on fedora core 3
Date Tue, 03 Jan 2006 23:07:41 GMT
Hi,

> Did you use the compiler flags given by apr-config?
>
> Try something like:
>
>  `apr-config --cc` `apr-config --cflags --cppflags` -c lala1.c
>  `apr-config --cc` `apr-config --cflags --cppflags` -c lala2.c
>  `apr-config --cc` `apr-config --link-ld --libs` -o lala lala1.o
lala2.o
>
> Probably using g++ instead of gcc (aka `apr-config --cc`) works if you

> need C++.

I have tried using the flags specified by apr-config and the error still
occurs.

> I guess you're using the older APR.
> I formerly met the same error with the older APR.

I am using apr-1.2.2 and the code you suggested appears in the apr.h
include file, so I am guessing that it is not the problem.

The line that is causing the problem is when I call:

apr_sleep(apr_time_make(0, 100000));

Any other suggestions?

Alex

Mime
View raw message